gravatar for nicholas.macknight

2 hours ago by

Hi,

I have previously and recently used WGCNA. I updated R to 3.6.2 and the installation of WGCNA is required and not working.

install.packages("WGCNA")

which gives me this response:

Package which is only available in source form, and may need compilation of C/C++/Fortran: ‘WGCNA’

Do you want to attempt to install these from sources? (Yes/no/cancel) Yes

installing the source package ‘WGCNA’

trying URL 'cran.rstudio.com/src/contrib/WGCNA_1.68.tar.gz'

downloaded 1.1 MB

  • installing source package ‘WGCNA’ ...
    * package ‘WGCNA’ successfully unpacked and MD5 sums checked
    *
    using staged installation
    ** libs
    xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun
    ERROR: compilation failed for package ‘WGCNA’
  • removing ‘/Library/Frameworks/R.framework/Versions/3.6/Resources/library/WGCNA’
    Warning in install.packages :
    installation of package ‘WGCNA’ had non-zero exit status

The downloaded source packages are in
‘/private/var/folders/nx/_07512cx3cdfz3464ts6glqw0000gn/T/Rtmp9dbXqM/downloaded_packages’

Any help or suggestions is appreciated.



Source link