Plink/VCFTools pairwise LD is always 1

0

Hi everyone,

I've been trying to calculate pairwise LD from my multisample VCF file. I tried with both Plink and VCFTools but in both cases the output was always (or almost always r2=1).

VCFTools:

vcftools --gzvcf file.vcf.gz --geno-r2 --ld-window-bp 10000 --out file_ld_10kb
CHR     POS1    POS2    N_INDV  R^2
1       827     4036    2       1
1       827     4285    2       1
1       827     4940    2       1
1       827     4988    2       1
1       827     6815    2       1
1       827     8515    2       1
1       827     9393    2       1
1       827     9422    2       1
1       3982    6384    2       1

Plink:

plink --vcf ganda_chr1.vcf.gz --r2

CHR_A         BP_A SNP_A  CHR_B         BP_B SNP_B           R2
     1          827    .      1         4036    .            1
     1          827    .      1         4285    .            1
     1         3982    .      1         6384    .            1
     1         4036    .      1         4285    .            1
     1         4036    .      1         4940    .            1
     1         4036    .      1         4988    .            1
     1         4285    .      1         4940    .            1
     1         4285    .      1         4988    .            1
     1         4285    .      1         6815    .            1

Because the values are so strange to me, maybe I'm doing something wrong. Appreciate some input on this matter.

Thanks anyway 🙂

Pedro


disequilibrium


LD


plink


linkage


vcftools

• 21 views



Source link