gravatar for h.gaikani

2 hours ago by

Canada/Vancouver/UBC

Hi all,
I downloaded jalview on ubuntu, but when I want to work with that, it says:

Error: LinkageError occurred while loading main class jalview.bin.Launcher
java.lang.UnsupportedClassVersionError: jalview/bin/Launcher has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 54.0

I tried to update my JAVA using this command: sudo apt-get install openjdk-11-jdk

But it returns:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
openjdk-11-jdk is already the newest version (11.0.10+9-0ubuntu1~20.04).
The following packages were automatically installed and are no longer required:
  libfprint-2-tod1 libllvm10
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 38 not upgraded.

Could you please kindly help?



Source link