gravatar for angus.j.g.campbell

9 hours ago by

I started getting a strange error when trying to load GEOquery with library(GEOquery).

Error: package or namespace load failed for ‘GEOquery’ in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]): namespace ‘rlang’ 0.4.9 is already loaded, but >= 0.4.10 is required

When I run

devtools::install_github('r-lib/rlang')

I get ...

Error in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]) : 
  namespace ‘rlang’ 0.4.9 is already loaded, but >= 0.4.10 is required

Has anyone dealt with this before? Restarting my R session has no effect.



Source link