Hello

I'm trying to install HTSeq as described in the link below

htseq.readthedocs.io/en/master/install.html#install

Cause I'm ussing ubuntu, I used this command

sudo apt-get install build-essential python3.6-dev python-numpy python-matplotlib python-pysam python-htseq

And I got error message

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'python3-htseq' instead of 'python-htseq'
Package python-matplotlib is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'python-matplotlib' has no installation candidate

As shown in the error message, I add letter 3 after python like below

sudo apt-get install build-essential python3.6-dev python3-numpy python3-matplotlib python3-pysam python3-htseq

And it seems to be installed!

And I try to confirm the program is well installed with this command in python

>>> import HTSeq

and I got error message

Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python3/dist-packages/HTSeq/__init__.py", line 13, in <module>
    from HTSeq._HTSeq import *
ModuleNotFoundError: No module named 'HTSeq._HTSeq'

and now I can't fix this problem yet

can anyone tell me how I can fix it?



Source link