I'm trying to run GATK on my machine as part of a pipeline using Phyluce. As per the instructions here (phyluce.readthedocs.io/en/v1.6.8/installation.html#why-conda), I downloaded GATK 3.7-0, activated a conda environment, and imported the GATK package into conda using the following code:

*conda activate phyluce-1.7.1

*gatk-register /PATH/TO/GATK-3.7/JAR/GenomeAnalysisTK.jar**

Terminal recognizes the command 'gatk -h' and provides the appropriate message. But, whenever I try to use one of the tools, eg:

gatk -T RealignerTargetCreator

...the following error crops up:

##### ERROR MESSAGE: Invalid command line: Malformed walker argument: Could not find walker with name: RealignerTargetCreator

I've tried messing with a couple of different versions of GATK, as well as different tool arguments to make sure this wasn't a one-off deprecated command, but I keep getting the same thing. I've also tried calling the jarfile directly (code below), but the result is the same.

java -jar /PATH/TO/GATK-3.7/JAR/GenomeAnalysisTK.jar
-T RealignerTargetCreator

Has anyone else experienced this issue, or know another way to run GATK?
Thanks in advance for your time.



Source link