gravatar for v.berriosfarias

2 hours ago by

Hello, I've just installed DeepMAsED, a software for assessing quality assembly of MAGs, it seems that the package is installed but I've got the next error message:

pip install DeepMAsED

ERROR: After October 2020 you may experience errors when installing or
updating packages. This is because pip will change the way that it
resolves dependency conflicts.

We recommend you use --use-feature=2020-resolver to test your packages
with the new resolver before it becomes the default.

tensorflow 2.2.0 requires scipy==1.4.1; python_version >= "3", but
you'll have scipy 1.5.2 which is incompatible. tensorflow 2.2.0
requires tensorboard<2.3.0,>=2.2.0, but you'll have tensorboard 2.3.0
which is incompatible.

Successfully installed DeepMAsED-0.3.1 opt-einsum-3.3.0

So DeepMAsED is installed, but I want to be sure that the packages that TensorFlow requires (which seems to be older versions of the cited packages) won't make me pass through future troubles.

I´ll be so thankful if you can clarify this.



Source link