gravatar for Merebellum

2 hours ago by

Hey!
I'm a beginner, and trying to install cutadapt and bowtie2 for some sequencing analysis. I can't get it to work, Even though there are countless threads and webpages about this. There must be something I am misunderstanding.Can somebody please help me. this is breaking me

I work on Windows 10 2016. I can't update to windows 10 2019 due to restrictions from my university (this would have solved all my problems. Then I could install ubunut with the linux subsystem. But the IT-department said no. So that is a dead-end)

Can someone please "check my math":

Installed python38 in windows command prompt added to path. installed pip, added to path. this works
error occurs when I try to install cutadapt, and bowtie2 using
pip install cutadapt; pip install bowtie2 (i've attached an error message for cutadapt at the end)
they suggest installing a C++ complier, visual studio but I installed it and it doesn't help me since I've no idea how to use it, and I have MinGW installed.

Installed MinGW by following the instructions on this link.
Not sure if I need to "creat a path" between python and MinGW, but it didn't help. So, I also tried installing Microsoft visual studio. This was probably foolish since that's more of an editor and I don't understand it yet. I can run py scripts there so that nice.

Then I tried Miniconda3 in hopes to install bioconda. But this was impossible as well. I added the three channels "default", "conda-forge", and "bioconda". it doesn't recognize or find bwa, and it has trouble with dnaio.
I've tried the follow two line, they do not work.
conda install bwa
conda create -n cutadaptenv cutadapt

Are there any suggestions. I need help.
Really sorry for the long text!

Below is the error for when i try installing cutadapt in the command prompt for windows:

C:Usersadmin>pip install cutadapt
Collecting cutadapt
  Using cached cutadapt-2.9.tar.gz (280 kB)
  Installing build dependencies ... done
  Getting requirements to build wheel ... done
    Preparing wheel metadata ... done
Collecting xopen~=0.8.4
  Using cached xopen-0.8.4-py2.py3-none-any.whl (8.3 kB)
Collecting dnaio~=0.4.1
  Using cached dnaio-0.4.1.tar.gz (123 kB)
Building wheels for collected packages: cutadapt
  Building wheel for cutadapt (PEP 517) ... error
  ERROR: Command errored out with exit status 1:
   command: 'c:python38python.exe' 'c:python38libsite-packagespip_vendorpep517_in_process.py' build_wheel 'C:UsersadminAppDataLocalTemptmp7wg2_4mc'
       cwd: C:UsersadminAppDataLocalTemppip-install-gw4wmje4cutadapt
  Complete output (21 lines):
  running bdist_wheel
  running build
  running build_py
  creating build
  creating buildlib.win32-3.8
  creating buildlib.win32-3.8cutadapt
  copying srccutadaptadapters.py -> buildlib.win32-3.8cutadapt
  copying srccutadaptalign.py -> buildlib.win32-3.8cutadapt
  copying srccutadaptfilters.py -> buildlib.win32-3.8cutadapt
  copying srccutadaptlog.py -> buildlib.win32-3.8cutadapt
  copying srccutadaptmodifiers.py -> buildlib.win32-3.8cutadapt
  copying srccutadaptparser.py -> buildlib.win32-3.8cutadapt
  copying srccutadaptpipeline.py -> buildlib.win32-3.8cutadapt
  copying srccutadaptreport.py -> buildlib.win32-3.8cutadapt
  copying srccutadaptutils.py -> buildlib.win32-3.8cutadapt
  copying srccutadapt_version.py -> buildlib.win32-3.8cutadapt
  copying srccutadapt__init__.py -> buildlib.win32-3.8cutadapt
  copying srccutadapt__main__.py -> buildlib.win32-3.8cutadapt
  running build_ext
  building 'cutadapt._align' extension
  error: Microsoft Visual C++ 14.0 is required. Get it with "Build Tools for Visual Studio": https://visualstudio.microsoft.com/downloads/

ERROR: Failed building wheel for cutadapt
Failed to build cutadapt
ERROR: Could not build wheels for cutadapt which use PEP 517 and cannot be installed directly



Source link